Network maintenance continuing
Incident Report for Natural HR
Resolved
We now believe the maintenance work to be completed and systems are back online - as this work took considerably longer than planned we will performing analysis and will share a report on what issues were experienced and how we can avoid a recurrence in the future.
Posted Apr 27, 2021 - 11:17 BST
Investigating
The planned maintenance work from this morning is over running - we are working hard to get all systems back online as soon as possible and will update as soon as this is completed. We apologise for any inconvenience.
Posted Apr 27, 2021 - 09:18 BST